SSL Error 61

Modified on: 2017-06-02 13:34:37 -0400


Due to changing Internet Security Protocol, Design Manager (along with all secure websites) had to update Website Certificates to keep up with changing security threats.  It is highly recommended that all users of the Design Manager Program use ONLY supported Operating Systems and also use the most updated version of the Citrix Receiver. 

Click here for the most current version of the Citrix Receiver.


If you are using Mac OS X version 10.6.8 – Snow Leopard – we highly suggest you upgrade to the latest Mac OS; however, you can download the older Citrix Receiver here; which as of the time this article was written, was the last supported Citrix Receiver for the Snow Leopard Operating System.




Did you find this helpful? Yes No

Can you please tell us how we can improve this article?